This page is continuously updated to reflect the current status of our systems. If you notice anything unusual that’s not reported here, please let us know at support@cteleport.com.
Resolved
The problem is fully resolved.
Monitoring
Problem has been resolved, we are monitoring if affected customers can resume their operations
Investigating
The problem has been identified, and we are working on a fix.