Live Chat Temporarily Unavailable
Resolved·Full outage

Global provider have resolved the incident.

Fri, Dec 5, 2025, 10:01 AM
(4 days ago)
·
Affected components
C Teleport Chatbot
Updates

Resolved

Global provider have resolved the incident.

Fri, Dec 5, 2025, 10:01 AM

Monitoring

Dear customer, Our live chat is partially recovered but currently experiencing degraded performance. We are monitoring the situation closely. If needed, please reach us at support@cteleport.com or https://cteleport.atlassian.net/servicedesk/customer/portals in the meantime. Thank you for your understanding. Kind regards, CTeleport Support Team

Fri, Dec 5, 2025, 09:25 AM(36 minutes earlier)

Monitoring

Our live chat has partially recovered after a global service issue. We are continuing to monitor the situation.

Fri, Dec 5, 2025, 09:18 AM

Monitoring

Dear customer, Our Crisp live chat is currently unavailable due to a global issue affecting the service. Please contact us at support@cteleport.com in the meantime. Thank you for your understanding. Kind regards, CTeleport Support Team

Fri, Dec 5, 2025, 09:13 AM
Powered by

This page is continuously updated to reflect the current status of our systems. If you notice anything unusual that’s not reported here, please let us know at support@cteleport.com.