Degraded flight search performance
Resolved·Degraded performance

Observed search performance is back to normal.

Wed, Nov 26, 2025, 10:45 PM
(1 week ago)
·
Affected components
C Teleport Web Application
C Teleport Mobile Application
Updates

Resolved

Observed search performance is back to normal.

Wed, Nov 26, 2025, 10:45 PM

Monitoring

Flight search performance is degraded due to one of the suppliers returning timeout errors. Some content might be temporarily unavailable. We are monitoring the situation.

Wed, Nov 26, 2025, 05:30 PM(5 hours earlier)
Powered by

This page is continuously updated to reflect the current status of our systems. If you notice anything unusual that’s not reported here, please let us know at support@cteleport.com.