C Teleport App and API are down
Resolved·Full outage

All services are now fully operational. We have verified that no data has been lost.

Wed, Oct 8, 2025, 05:59 PM
(2 months ago)
·
Affected components
C Teleport Web Application
C Teleport Mobile Application
Updates

Resolved

All services are now fully operational. We have verified that no data has been lost.

Wed, Oct 8, 2025, 05:59 PM

Monitoring

All services are back online. Team is validating if any data was lost during this incident.

Wed, Oct 8, 2025, 05:51 PM

Monitoring

Root cause has been identified, services are getting back online

Wed, Oct 8, 2025, 05:43 PM

Investigating

C Teleport APP and API are down, our team is investigating the impact.

Wed, Oct 8, 2025, 05:28 PM(15 minutes earlier)
Powered by

This page is continuously updated to reflect the current status of our systems. If you notice anything unusual that’s not reported here, please let us know at support@cteleport.com.