Data synchronization between our accounting system and data sources has been completed. If our customers encounter any issues related to trade credit and statement of their account, we recommend that they contact the support team.
Resolved
Data synchronization between our accounting system and data sources has been completed. If our customers encounter any issues related to trade credit and statement of their account, we recommend that they contact the support team.
Identified
Data synchronization is currently in progress. The estimated time to completion is approximately 1 hour and 30 minutes.
Identified
We have identified inaccuracies in the Statements of Account and Trade Credit balance for certain accounts. Our team has pinpointed the root cause and is actively working on a resolution.
This page is continuously updated to reflect the current status of our systems. If you notice anything unusual that’s not reported here, please let us know at support@cteleport.com.