Resolved
Hotels search functionality is fully resolved.
Monitoring
Hotel destinations search functionality has been restored. We’re monitoring and checking for possible performance degradation.
Identified
The issue is caused by our hotels provider. We are escalating this to their team and will monitor their remediation efforts.
Investigating
Currently it is not possible to select a hotel destination for new hotels search. Our team is running investigation
This page is continuously updated to reflect the current status of our systems. If you notice anything unusual that’s not reported here, please let us know at support@cteleport.com.